GpgOL: Blocks sending mails from outbox if a mail is selected in outbox
Closed, ResolvedPublic

Description

Originally reported in wald https://wald.intevation.org/forum/message.php?msg_id=5676&group_id=11

To reproduce i did:

  • Work Offline
  • Write a mail (non crypto) and click send
  • Open outbox and select the mail
  • Disable Work Offline
  • Hit "Send all"

If GpgOL is disabled the mail is sent. If GpgOL is enabled the mail is not sent.

It also gets a different icon and is no longer written in italics.

I could not see a problem If I just had the Outbook open without "work offline" in the mix. Then the Mail is selected quickly, changes from italics to no italics but is sent correctly.

I think the problem is with the selction change event. When we query for selection item (1) we trigger an itemLoad event which apparently causes this behavior. I've disabled everything else in our event handling code so we don't touch the mail at all (non crypto mails we never touch much).

An idea for a fix would be to check if we have a selection change but no preview (like we have in the outbox) and stop there before accessing the selection item.

aheinecke changed the task status from Open to Testing.Feb 27 2018, 7:12 AM

My test works now with this commit.

aheinecke closed this task as Resolved.Mar 7 2018, 2:21 PM