crash when checking signature of a file
Closed, ResolvedPublic

Description

I upgraded from GPG4Win 3.0.2 to 3.0.3. I use Win 7, 64bit.

  • sign a file of your choice
  • now check the file you just signed, by right-clicking on the file in the Win explorer and then by selecting from the appearing context menu "more GpgEX options->check"

result: Kleopatra tells you that the signature is correct.

  • click OK

result: Kleopatra crashes and Windows attempts to kill it. Afterwards one gets this error message:

This is a regression to Gpg4Win 3.0.2.

Details

Version
3.0.3
uwestoehr created this task.Mar 3 2018, 3:48 AM
uwestoehr updated the task description. (Show Details)
Jawsh added a subscriber: Jawsh.Mar 3 2018, 7:58 AM

Hey, @uwestoehr. It looks like you're having the same issue that I reported: T3761.

It looks like you're having the same issue that I reported: T3761.

Thanks. Seems to be the same problem as you have. But since your bug is fixed and the bug breaks an essential function in GPG4Win I wonder why no new GPG4Win version has yet been released.

aheinecke closed this task as Resolved.Mar 7 2018, 3:11 PM
aheinecke added a project: Duplicate.
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

Yes sorry, I decided against a release specially for that is it is not super critical, no data loss.

Anyhow we are moving towards a 3.1.0 soon. I've uploaded a beta today. https://files.gpg4win.org/Beta/gpg4win-3.1.0-beta-current.exe