Kleopatra: Crash After Verifying Detached Signature
Closed, ResolvedPublic

Description

Expected behaviour

Kleopatra verifies a detached signature without issue.

Actual behaviour

Kleopatra crashes after verifying a detached signature.

Steps to reproduce the behaviour

  1. Launch Kleopatra
  2. Click Decrypt/Verify
  3. Select a detached signature to verify.
  4. A new window appears and the file is verified.
  5. Click OK to close the window.
  6. Kleopatra crashes.

Additional information

GpgEX version 1.0.5 (64 bit)

I tried to re-install Gpg4Win but that did not resolve the issue. I have only tried verifying detached signatures. I asked another person to reproduce the issue but they could not do so. Verification works without issue via command line.

Error windows:

[Window Title]
kleopatra.exe

[Main Instruction]
kleopatra.exe has stopped working

[Content]
Hang on while Windows reports the problem to Microsoft...

[Cancel]
[Window Title]
kleopatra.exe

[Main Instruction]
kleopatra.exe has stopped working

[Content]
A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

[Close program]

Note: The following window only appears if verification was performed via the context menu (right-click → More GpgEX options → Verify)

---------------------------
GpgEX
---------------------------
Error returned by the GnuPG user interface:

End of file
---------------------------
OK   
---------------------------

Details

Jawsh created this task.Jan 29 2018, 11:09 AM
al_b added a subscriber: al_b.Jan 29 2018, 8:31 PM

Confirming this bug in Gpg4win version 3.0.3 (previous version was OK).

kleopatra.exe crashes every time after closing verification result window.

Microsoft Windows 10 Enterprise (x64) Build 16299 (1709/RS3), fully patched (with latest Spectre patches as well).
CPU: AMD

aheinecke triaged this task as High priority.Jan 30 2018, 7:54 AM
aheinecke edited projects, added gpg4win; removed gpgex.
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

Thanks for your report. I tried this several times. Could not reproduce it at first but I could get it to crash sometimes. Even without GpgEX just by double clicking the signature file.

I'll look into it.

aheinecke changed the task status from Open to Testing.Jan 30 2018, 8:16 AM

Ah under Linux we ran into an assert which made finding the problem easy. The bug was introduced by the fix for T3602. Will be fixed in the next release. Apologies for the inconvenience.

clpo13 added a subscriber: clpo13.Feb 16 2018, 7:03 AM

A beta of the next version where this is fixed is available now: https://files.gpg4win.org/Beta/gpg4win-3.1.0-beta-current.exe

aheinecke closed this task as Resolved.Mar 8 2018, 8:26 AM

Got confirmation In Bugs.kde.org that this is fixed https://bugs.kde.org/show_bug.cgi?id=389792 as my tests also showed this -> resolved.