Kleopatra crashes again in Gpg4win 3.1.0 beta 38
Closed, ResolvedPublic

Description

Hi
Kleopatra crashes in Gpg4win 3.0.3 when closing.
Kleopatra works fine in Gpg4win 3.1.0 beta 32.
In Gpg4win 3.1.0 beta 38 Kleopatra crashes again, tested by checking a signature of a file,
I can not find any log-file. I switched back to Gpg4win 3.1.0 beta 32.

Microsoft Windows [Version 10.0.16299.309]
"Beschreibung
Name der fehlerhaften Anwendung: kleopatra.exe, Version: 3.1.0.0, Zeitstempel: 0x00000000
Name des fehlerhaften Moduls: libgpgmepp-6.dll, Version: 0.0.0.0, Zeitstempel: 0x00000000
Ausnahmecode: 0xc0000005
Fehleroffset: 0x00008a10
ID des fehlerhaften Prozesses: 0x3260
Startzeit der fehlerhaften Anwendung: 0x01d3c35def591045
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Gpg4win\bin\kleopatra.exe
Pfad des fehlerhaften Moduls: C:\Program Files (x86)\Gpg4win\bin\libgpgmepp-6.dll
Berichtskennung: 56be6127-2038-463f-81ed-eda26c91dd06
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: "

Regards

Details

PaSch created this task.Mar 26 2018, 1:06 PM
aheinecke triaged this task as High priority.Mar 26 2018, 3:26 PM
aheinecke added a subscriber: aheinecke.

Thanks for trying out the beta and your report.

Sadly, I can't reproduce any crash there. I've also reviewed the changes made to kleopatra between the two betas and did not find anything suspicious.

What I tried was:
Verify an untrusted signature, close Kleo
Verify a, detached (.sig), trusted signature, close Kleo (~20 times)
Verify an opaque signature.
Verify with an empty Homedir.

Can you tell me more about how it crashes for you? This would help me to further reduce variables where our setup could differ.

  1. Does this reliably happen for you or only sometimes?
  2. Did I understand you right that it crashes if you Quit Kleopatra (or does it crash if you close the verification window?)
  3. Is it an S/MIME or OpenPGP signature?
  4. Is it a detached (small .sig or so file next to a larger file to be verified) or opaque (Save As button available at the end of the operation) signature.

Kleopatra does not write a log file but it logs a bit as "Debug Output". Debug Output is visible with DbgView from Microsoft: https://docs.microsoft.com/en-us/sysinternals/downloads/debugview
lines starting with "org.kde.pim" come from Kleopatra.

Thanks.

  1. Do you have some S/MIME keys also in Kleopatra?
PaSch added a comment.Mar 26 2018, 5:52 PM
  1. it is reproducible
  2. Kleopatra crashes at the end of the verification of a signature
  3. it is a openPGP signature
  4. please see first picture
  5. I have only openPGP certificates in Kleopatra

I have reinstalled Beta 38 again for testing.

In gpg4win-3.1.0-beta32 I can import the both certificates to Kleopatra without error.

The error appears in gpg4win-3.1.0-beta38, if the both certificates
ID: 0x42D876082688DA1A
ID: 0x7CBD620BEC70B1B8
are not imported in Kleopatra.


If both certificates are imported in Kleopatra, no error appears in gpg4win-3.1.0-beta38.

Again, thanks for your time testing it again.

The big difference to my tests was probably that I mostly tested with the certificates imported.

I can reproduce the problem this way. Out of 5 tries it crashed for me twice. And with a similar broken output that is in your crashing screenshot.

aheinecke changed the task status from Open to Testing.Mar 27 2018, 11:34 AM

Got it. This was a bug that was around for ages but only started to occur in the verificationresult when we started in 3.0 to show the KeyID / Options for the unknown certificates.

The problem was an unitialized pointer in one of our libraries. As long as this pointer was NULL (luck / timing) everything was Ok, but if it pointed to some random value we had the crashes. This would also happen in GpgOL and might explain some reports about random crashes in there.

That this only started again with -beta38 and does not happen for your with -beta32 is mostly luck. Different timings / memory layout would change the behavior.

aheinecke closed this task as Resolved.Apr 13 2018, 11:20 AM
aheinecke claimed this task.

3.1.0 is released and this issue is to our knowledge fixed.