gpgol does not decrypt mails send by Evolution
Closed, ResolvedPublic

Description

Encrypted mails send by Evolution 3.26.6 on fedora 27, cant be decrypted by gpgol in Outlook 365 (Windows 10).
It seems, that these mails are even not recognized as encrypted.
Sending and encrypting by gpgol works fine.
Problem occurs with gpgol version 2.0.6 and the gpgol version in gpg4win beta 3.10-beta48.

Details

Commits
rOdc48589b3d42: Handle weirdly constructed PGP/MIME mails
Version
gpgol version 2.06 and beta
Fgp created this task.Apr 6 2018, 11:57 AM
aheinecke triaged this task as Normal priority.Apr 9 2018, 8:55 AM
aheinecke added a subscriber: aheinecke.

Thanks for the report.

Strange, in the past we had reports that interoperability with Evolution and Outlook 365 works now.

Could you please save such a mail from Outlook and attach the .msg file here? Or send it to aheinecke@intevation.de I don't need to be able to decrypt it but this should allow me to figure out why our parser does not recognize it.

I've got an example mail. The problem is that the mail itself is "Content-Type: multipart/mixed; boundary="_003_DB4PR08MB01092D175DE8C1861B5D0BC197BF0DB4PR08MB0109eurp_"
"

And then:

 This is a multipart message in MIME format.

--_003_DB4PR08MB01092D175DE8C1861B5D0BC197BF0DB4PR08MB0109eurp_
Content-Type: application/pgp-encrypted;
	name="ATT00001.gpg"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
	filename="ATT00001.gpg"

Version: 1

--_003_DB4PR08MB01092D175DE8C1861B5D0BC197BF0DB4PR08MB0109eurp_
Content-Type: application/octet-stream;
	name="encrypted.asc"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
	filename="encrypted.asc"

-----BEGIN PGP MESSAGE-----

A correct message would have a top level mime part of application/pgp-encrypted and not multipart/mixed. Maybe a bug in Evolution?

GpgOL bails out if the top level content type is multipart/mixed because it does not look like an encrypted mail.

I can change it though to accept such messages. Accepting as much as possible, even if its broken is good.

Fgp added a comment.Apr 11 2018, 8:15 AM

I'm not sure about that (Bug in Evolution), because I see ist only in E-Mails send by Evolution via Mircosoft (outlook.com) and not if Mails werden send by Evolution via Google (gmail.com).

But nevermind, it would bei great if you can change it. Thanks!

aheinecke changed the task status from Open to Testing.Apr 11 2018, 2:24 PM

Right, outlook.com is often problematic, although it might be a generic Exchange 2016 problem. Outlook.com and Exchange 2016 behave much the same.

Anyway. It's fixed now. When GpgOL sees a multipart/mixed MIME mail without a body part it looks at the first attachment to see if the attachment looks like a PGP/MIME part. This detects your example mail as encrypted and correctly fails for me with "No secret key" :-)

aheinecke closed this task as Resolved.Apr 13 2018, 11:21 AM
aheinecke claimed this task.

3.1.0 is released and this issue is to our knowledge fixed.