Latest GPG signed/encoded mail in Inbox and any X.509 signed message can't be moved to folder
Closed, ResolvedPublic

Description

When receiving a signed/encrypted message, it can't be moved to a folder before receiving another mail, neither by Drag&Drop nor by context menu. This is not related to display order, i.e. if I resort mails by content, so the mail is not the first displayed any more, it still can't be moved.

When receiving a X.509 signed message, it can't be moved to a folder, neither by Drag&Drop nor by context menu, even if receiving more mails afterwards.

If trying to open the (write) "new mail" window afterwards, Outlook crashed.

Details

Version
Gpg4win 3.1.0. beta 48; Outlook 2010 32-bit, Exchange Server
JJworx created this task.Apr 12 2018, 12:41 PM
aheinecke triaged this task as Normal priority.Apr 13 2018, 8:07 AM
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

I think you are running in the infamous T3459 "As long as the decrypted content of a crypto mail is loaded a mail can't be moved" You have to unselect the mail and then move it without opening it. E.g. by right clicking it. I know this is horrible and it's a major problem but I don't see how we can fix it in our architecture. As we replace the mail content with the decrypted stuff we have to prevent "Write" Events by Outlook. For Move if you block a write event, the move fails. But we don't have any idea in our addon when a write comes from a move. I spent a lot of time on this and have not yet found a good solution. But I think the workaround is kinda ok.

And yes I would love to show a warning / info about this. But I do not know when a move takes place. Outlook sends out write events several times if you "modify" a mail (by replacing the content with the decrypted content).

> If trying to open the (write) "new mail" window afterwards, Outlook crashed.
I'll try to reproduce this.

aheinecke closed this task as Resolved.Jun 18 2018, 4:30 PM
aheinecke added a project: Duplicate.

I'm closing this as duplicate of T3459