Response to signed mail just shows the original signed part of the mail in Outlook after verification
Closed, ResolvedPublic

Description

Hello,

I have sent out an Email signed inline. The answer I receive will just show my original in Outlook - the part that has been sent in response just is discarded.
Outlook: Version 1804 (Office365, Build 9226.2114) on Windows 10

Best
Marcus

Hello,

I'm not sure I understand your Problem. For me it works as it should.

Could you please clarify that we can try to reproduce.

Like my test was:

  • Activated "PGP/Inline" in GpgOL Options.
  • Sent myself a signed mail.
  • Replyed to the signed mail with a signed reply, using the inline editor in the message list.

-> New mail showed the correct reply content and the quote of the replied to message.

Thanks.

Hello,

  1. Create Mail and sign with PGP/inline activated
  2. Send mail to someone else who does not use gpg etc.
  3. Get a response including full quote of your email

Thanks.
MArcus

aheinecke triaged this task as High priority.May 11 2018, 9:02 AM

I understand the Problem. Your recipient formatted the reply in such a way that GpgOL does not detect that the original message is Quoted, verifies it and shows only the verified part.

In older versions we had code that would bail out if some text was detected above a PGP Message. But this had also some problems when there was some weird automatic stuff inserted above the message. :-/ Something like

"This mail was scanned by the super duper virus detection tool:"

I've just tested and the way that Outlook itself formats such a reply could trigger this behavior. :-/

I assumed the usual:

Foo@bar.baz wrote:

test

With the quotation " > " would be more universal. And in that case the message would not be parsed.

aheinecke changed the task status from Open to Testing.May 11 2018, 9:37 AM
aheinecke closed this task as Resolved.
aheinecke claimed this task.

The change was released with Gpg4win-3.1.2