GpgOL: Embedded image not visible in forwarded email
Closed, ResolvedPublic

Description

Moved out from T4321:

But when I copy past an image in the email, the image is not visible at all when I do the forward (in the second email)

The image is visible in the first email, but not in the forwarded email (the second one).
I am not removing it and pasting it again, I just do the forward without touching it.

It works correctly if I don't sign the email. the image is also correctly send. It does not work when I sign the email.
I did the test without attachment, just a message and a pasted picture.

Thanks for your work.
Regards

EDIT: In the sent mailbox, the picture is not visible is the first email as well.
Very curious behaviour

aheinecke added a subscriber: MThib.

I can reproduce it. For me the image is properly attached, I can access the file, but the embedded image does not work. This will be because the content_id is mixed up. I don't know why this happens yet.

We did not remove the "<>" from the content id. This worked for the first display but when forwarding they got doubled and it broke.

aheinecke changed the task status from Open to Testing.Jun 4 2019, 10:41 AM

Works for me

aheinecke closed this task as Resolved.Sep 9 2019, 11:22 AM