Certificate certifications
Closed, ResolvedPublic

Description

Viewing the certifications of a certificate (both mine)
no pub key???

Details

Version
3.1.7

Related Objects

StatusAssignedTask
Resolvedaheinecke
Resolvedaheinecke
FabioCarpi updated the task description. (Show Details)
FabioCarpi removed a project: Bug Report.
FabioCarpi removed a subscriber: Bug Report.
aheinecke triaged this task as Normal priority.
aheinecke added a subscriber: aheinecke.

Thanks for the report. Indeed I can also reproduce it with my own key. For signatures from expired / revoked / disabled keys it shows "No public key" because GnuPG returns the same error in that case. We can fix that by looking up the key ourself.

aheinecke changed the task status from Open to Testing.Apr 15 2019, 8:03 AM

Fixed with: https://commits.kde.org/libkleo/245eff174331c49264d1248c529e0276e02e9e29

For my key it looks like:

key expired and key revoked are both new states.

aheinecke closed this task as Resolved.Sep 9 2019, 11:22 AM