Release Scute 1.6.0
Closed, ResolvedPublic

Related Objects

werner created this task.Sep 6 2019, 11:49 AM
gouttegd claimed this task.Sep 9 2019, 1:31 AM
gouttegd added a subscriber: gouttegd.

I just checked that Scute builds cleanly on Slackware, Debian, and in a cross-compilation setup against Mingw32.

Of note, with @werner we would like to move the home page from its own domain (scute.org) to a folder under gnupg.org/software. This imply converting the HTML pages in doc/website to org-mode and moving them to the gnupg-doc repository. And for consistency, we should also make sure the manual (currently available on scute.org) is published under https://gnupg.org/documentation/manuals/ along with the manuals of the other GnuPG components.

However I don’t think the 1.6.0 release needs to be delayed for that. I plan to do the release with the current documentation still in place. I’ll send patches later to update gnupg-doc, and when the new pages will be online on gnupg.org, I’ll remove the website’s sources from the Scute repository.

With the build problem on Mac OS now fixed with d551cf9, barring any last minute issue I plan to do the actual release by the end of the day tomorrow (10 September).

aheinecke added a subscriber: aheinecke.EditedSep 10 2019, 11:26 AM

In my debian buster pbuilder enviornment I got the following failure when packaging master (beta195):

FAIL: t-getinfo
===============

gpgconf: Configuration file of component gpg-agent is broken
gpgconf: Note: Use the command "gpg-agent --gpgconf-test" to get details.
scute: agent_connect: cannot connect to GPG agent: No agent running
scute: scute_gpg_err_to_ck: Error occurred: No agent running (Unspecified source)

t-support.h:271: General error
FAIL t-getinfo (exit status: 1)

But when I did make check in the interactive session of the same environment they passed. And distcheck also passed for me on buster.
I speculate that the test might be run too early or has a problem with parallel builds. Because when I've built the same tarball with the same command again the tests also passed. So I can't even reproduce this failure.

I could not reproduce such a failure either under any conditions.

It seems the test failed because scute could not start the agent. I don’t quite see what in the build system could cause that. The tests are “self-contained”, each test can be run independently, in any order. They don’t depend on anything else than the scute.so module itself.

It’s unfortunate, but given that I can’t reproduce I am not keen on delaying the release any further.

gouttegd closed this task as Resolved.Sep 13 2019, 12:19 AM
gouttegd set External Link to https://lists.gnupg.org/pipermail/gnupg-announce/2019q3/000441.html.