Kleopatra crashed with qwindows.dll.
Testing, NormalPublic

Description

I have a user that uses GPG4Win and Kleopatra. When they try to create a key pair through the gui, it disappears/crashes.
Have removed and reinstalled the software. This is a newly imaged system. If they use the command line to create a key pair, it works fine.
Thoughts?
This what I have in the event viewer:
Log Name: Application
Source: Application Error
Date: 9/23/2020 12:05:05 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: XXXXXXXX(redacted)
Description:
Faulting application name: kleopatra.exe, version: 3.1.3.0, time stamp: 0x00000000
Faulting module name: qwindows.dll, version: 5.10.1.0, time stamp: 0x5b892f34
Exception code: 0xc0000005
Fault offset: 0x0000b20b
Faulting process id: 0x94
Faulting application start time: 0x01d691c338e69f38
Faulting application path: C:\Program Files (x86)\Gpg4win\bin\kleopatra.exe
Faulting module path: C:\Program Files (x86)\Gpg4win\bin\platforms\qwindows.dll
Report Id: 3fbd75d8-4dc6-44b3-aacc-c4df9e8b704e

Details

Version
3.1.3.0

Any ideas? Is there any other info needed that could help move this along?

aheinecke changed the task status from Open to Testing.Nov 30 2020, 10:51 AM
aheinecke added a subscriber: aheinecke.

Hi,

there was an issue that has been fixed in 3.1.14 which was creating problems / crashes when the home directory of a user had a unicode character in it. So maybe your one user had such a username?

Could you please retest with the recently released version 3.1.14? Thanks!

aheinecke triaged this task as Normal priority.Nov 30 2020, 10:52 AM