Diffusion GnuPG 813e24108a13

gpg: Fix SOS handling with libgcrypt version <= 1.8.

Authored by gniibe on Oct 30 2020, 9:03 AM.

Description

gpg: Fix SOS handling with libgcrypt version <= 1.8.

* g10/misc.c (checksum_mpi): Don't depend new feature
of gcry_mpi_print which supports opaque MPI.
  • GnuPG-bug-id: T5116
  • Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>