Diffusion GPGME 153f1128f81a

core: Use a better name for the internal synchronous wait.

Authored by werner on Jun 14 2019, 10:12 AM.

Description

core: Use a better name for the internal synchronous wait.

* src/wait.c (_gpgme_wait_on_condition): Rename to ...
(_gpgme_sync_wait): this.  Small code refactoring.
(_gpgme_wait_one, _gpgme_wait_one_ext): Remove and change all callers
to use _gpgme_sync_wait.
* src/fdtable.c (_gpgme_fdtable_run_io_cbs): Move TRACE up.
  • Signed-off-by: Werner Koch <wk@gnupg.org>

Details

Committed
wernerJun 14 2019, 10:16 AM
Parents
rM28e620fa169d: core: Refactor the wait code utilizing the new fdtable.
Branches
Unknown
Tags
Unknown