GpgOL: can't open encrypted emails in "Sent" Folder
Closed, ResolvedPublic

Description

I can't read my emails in "Sent" folder in Outlook 2003 using latest stable
release of Gpg4win (Version 2.0.0 released 2009-08-07) using the GpgOL-plugin.
The "decrypted" message body contains only garbled characters. The recipients'
MUAs (Outlook 2007 + Thunderbird 3 w/enigmail-plugin) can successfully decrypt
the message though.

Interestingly enough, before I open them, the encrypted messages in the "Sent"
folder do not show the GpgOL icon, but instead the default Outlook icon for
S/MIME encrypted messages.

I'm wondering if anybody else has had similar problems?

Jochen

Windows XP, SP2, german
MS-Outlook 2003, german
GnuPG: 2.0.12
Kleopatra: 20090807
GpgOL: 1.0.0

jroemmler added a subscriber: jroemmler.

Seems to be the same issue like T1110, right?

Nope, I'm using MS Outlook 2003 and #1110 crashes in Outlook 2007, whereas his
Outlook 2003 seems to work fine for him.
BTW: My Outlook 2003 doesn't crash, it just shows garbled content in the message
body (but that may be by luck).

sorry, jroemmler, I have mixed the issue numbers.
Again: I think your issue is the same problem like T1137 (GpgOL could not
decrypt/verify messages in "sent items" folder if sime support is disabled).
Can you confirm it?

Yes, this looks very familiar to me, although I thought the problem only occurs
if I both sign and encrypt the message.
I can't remember GpgOL's S/MIME support setting; and I'm unable to verify,
because I uninstalled it in the meantime (switched from OpenPGP to S/MIME
solution). You can mark #1130 a duplicate of #1137 if you like (though mine was
created 10 days earlier).

werner closed this task as Resolved.Sep 25 2009, 5:41 PM
werner added a subscriber: werner.

Duplicate of T1137

werner removed jroemmler as the assignee of this task.

See T1137