GpgOL: Move/Copy/Save/Export mail doesn't work
Closed, ResolvedPublic

Description

I’m using Outlook 2013 64 bit on a Win 8.1 64 bit computer (also tested on Win 7
32 bit with Outlook 2010 32 bit). Installed gpg4win-3.0.0-beta194 and replaced
both gpgol.dll (32 and 64 bit) with latest version (2.0.0-beta211). This version
works best for me (bugs I found were gone and moreover this is the most user
friendly way of using gpg with Outlook). However I unfortunately did find an
annoying bug: Moving of mail items between folders (f.e. imap folder item to
offline Outlook folder) do not work for an encrypted mail, while this does work
with unencrypted mail. I am using the experimental simple user interface
setting, but also changing this setting doesn’t resolve this. Dragging the mail,
using Move to folder option or copy to folder option, nothing works. In all the
times I tried moving it, it mysteriously succeeded once, but couldn’t repeat
that “success” anymore. Also rebooted pc, checked day after, etc.
Hopefully this problem van be repeated so it can be solved in a future version,
thanks.

Details

Version
2.0.0-beta211
Dr_IT set Version to 2.0.0-beta211.
Dr_IT renamed this task from GpgOL: to GpgOL: Moving mail item to other folder doesn't work.
Dr_IT added a subscriber: Dr_IT.
Dr_IT renamed this task from GpgOL: Moving mail item to other folder doesn't work to GpgOL: Move/Copy/Save/Export mail doesn't work.Dec 22 2016, 10:38 PM
Dr_IT raised the priority of this task from Normal to High.Dec 22 2016, 10:41 PM

I tested some more and found out problem is bigger than only move. Copy also
doesn't work, but save message as .msg or exporting to pst folder doesn't work
also. So it seems nothing can be done with message to save or archive it
somewhere else then orginal folder. Tried official stable version of gpgol, but
this has the same problems. Also tried this stuff on android with K9 client and
openkeychain, whereas these problems do not exist, it simple works as expected.

Hi,

Again thanks for your feedback on the GpgOL-Beta. You might want to give the
latest one from http://files.gpg4win.org/Beta/gpgol/ (beta-246 currently) a try
it's much improved and there were several potential crashes fixed. I'm currently
working on an improved certificate selection and certificate details dialog and
then we will release a new gpg4win beta with that.

To your problem: Yes this is a serious problem, but we currently don't have a
solution for this, only a workaround. The workaround is to do the Copy / Move /
Modify while the mail is not shown decrypted. In the current beta:

If you unselect the crypto mail you can move / copy / modify (e.g. flag) the
message through right clicking it.

To save the message as .msg you can drag & drop it (even when opened) to a
target windows explorer folder.

An opened messaage can still be moved to trash. Any other moves will sadly
result in an "File name or directory name is not valid" error.

We inform the user about this only when he tries to modify a mail (see attached
screenshot) we should probably also do that for other things.

The underlying problem is pretty complicated and we spent a lot of time
struggling with that, but basically we must prevent outlook from saving the
decrypted content. Otherwise the mail will break and can no longer be shown in
other MUAs. And worse the Plaintext may be resynced to the server. One
workaround we had was to restore the crypto contents before outlook saved the
mail then decrypt it again. But this caused several other problems. E.g. Outlook
resynced the mail to imap and Signatures might be broken, and if we did this at
the wrong time outlook would do into an indefinite sync loop. So we decided
better to have clear workarounds and be otherwise stable then to have buggy /
strange behavior.

As a user are these workarounds acceptable to you.

As a user are these workarounds acceptable to you. < This should have been a
question ;-)

Dr_IT added a comment.Jan 13 2017, 5:03 PM

Well if this works, i could live with it temporary, but not indefinitely. While
this f.e. for my wife will not work, not user friendly enough :(
So hopefully you can work this out somewhere in the future, but from you reply i
understand this is not something i should expect soon (or ever)...
I'm also testing EM Client which has promised to come with PGP support, so will
wait a little longer and then decide which (best available) way i'm going to use
(now temporary disabled online encryption).

While this f.e. for my wife will not work, not user friendly enough :(

I'm really really sad to hear that. I was hoping this was acceptable to
"non-technical" users just one of the quirks users eventually get used too :-(

I tried to think about this more but I don't see another solution then:
a) Prevent Outlook from saving any changes after a message was decrypted

  • This is the current behavior and leads to the problem.

b) When Outlook want's to save a mail remove the plaintext, restore the
encrypted contents and save the changes to the encrypted mail.

  • This has a serious downside that it does trigger a full resync of the mail

because outlook thinks the attachments have changed. When closing Outlook this
also somehow brought Outlook in a state that it kept indefitely syncing a single
mail :-/. It also broke the signatures on singed only mails because the MIME
boundarys could not be restored. In general I found it much more unstable and
buggy then a clear "Sorry you can't do that". :-/

Dr_IT added a comment.Jan 16 2017, 4:28 PM

Well if my wife is representable for a lot of "ordinary" users (and i
think she is), it will be hard to explain it to them and after that let
them remembering it or the future :(
Also this will not be the solution (i think) for when i want to move a
lot of mails (use case: mailbox space full, so want to archive older
mail to local folder by moving them from imap folder)?

I understand your frustration (and appreciate you're looking for
solutions), you to try and work around some of Outlooks mechanisms,
while not have access to the code or something like that...
Option A looks like the best option, but i'm guessing this is something
Microsoft should change?

Btw in the test fase i did move encrypted mail with EM Client (which
doesn't understand PGP yet) and this was tricky. Sometimes the message
afterwards wasn't readable anymore in Outlook with gpgOl, so if this
could happen too with the workaround it is a no go (as email now
permanently gone/unreadable)...

  • Original Message ------

From: "Andre Heinecke via BTS" <gnupg@bugs.g10code.com>
To: aheinecke@intevation.de; dr_it@mailbox.org
Sent: 16-1-2017 15:15:14
Subject: [issue2883] GpgOL: Move/Copy/Save/Export mail doesn't work

Andre Heinecke <aheinecke@intevation.de> added the comment:

While this f.e. for my wife will not work, not user friendly enough

:(

I'm really really sad to hear that. I was hoping this was acceptable to
"non-technical" users just one of the quirks users eventually get used
too :-(

I tried to think about this more but I don't see another solution then:
a) Prevent Outlook from saving any changes after a message was
decrypted

  • This is the current behavior and leads to the problem.

b) When Outlook want's to save a mail remove the plaintext, restore the
encrypted contents and save the changes to the encrypted mail.

  • This has a serious downside that it does trigger a full resync of

the mail
because outlook thinks the attachments have changed. When closing
Outlook this
also somehow brought Outlook in a state that it kept indefitely syncing
a single
mail :-/. It also broke the signatures on singed only mails because the
MIME
boundarys could not be restored. In general I found it much more
unstable and
buggy then a clear "Sorry you can't do that". :-/


GnuPG's BTS <gnupg@bugs.g10code.com>
<T2883>


aheinecke closed this task as Resolved.
aheinecke added a project: Duplicate.

I'm closing this as a duplicate of T3459 even if this bug is older we used it to discuss side topics.

Just as a note as you were the first to report this: I've finally found a solution. In the next version it will be possible to move around crypto mails. Hopefully your wife can then use GpgOL :-)

Dr_IT added a comment.Jun 26 2018, 5:17 PM

Good news! :)

  • Original Message ------

From: "aheinecke (Andre Heinecke)" <noreply@dev.gnupg.org>
To: dr_it@mailbox.org
Sent: 26-6-2018 16:33:52
Subject: [Task] [Commented On] T2883: GpgOL: Move/Copy/Save/Export mail
doesn't work

aheinecke added a comment.

Just as a note as you were the first to report this: I've finally found
a solution. In the next version it will be possible to move around
crypto mails. Hopefully your wife can then use GpgOL :-)

TASK DETAIL
https://dev.gnupg.org/T2883

EMAIL PREFERENCES
https://dev.gnupg.org/settings/panel/emailpreferences/

To: aheinecke

Cc: aheinecke, Dr_IT, Rafixmod, Mak, gp_ast

This is an automated email from the GnuPG development hub. If you have
registered in the past at https://bugs.gnupg.org/ your account was
migrated automatically. You can visit https://dev.gnupg.org/ to set a
new password and update your email preferences.