GPGOL Crashes Outlook 2016 when cancelling an inline reply with Escape
Closed, ResolvedPublic

Description

GPGOL Plug-in file version is 2.1.0.4953.
Window Server 2008 R2.
Outlook 2016

  • I hit Reply-All to an email conversation.
  • I start to type a reply.
  • Reconsider, hit Escape to cancel the message.
  • Upon canceling the message, Outlook crashes and will disable the plug-in for the next session.
magnotta created this task.May 3 2018, 8:12 PM
magnotta updated the task description. (Show Details)
aheinecke renamed this task from GPGOL Crashes Outlook 2016 to GPGOL Crashes Outlook 2016 when cancelling an inline reply with Escape.May 4 2018, 8:58 AM
aheinecke claimed this task.
aheinecke triaged this task as High priority.
aheinecke added a project: gpgol.

Thank you for the report. I can reproduce the problem. I extended the title a bit so that its easier to find for others who might also see this.

For me it only happens if I cancel the reply through Escape and then select to discard changes.
If I cancel through the discard button it does not crash. Similarly if the reply is opened in a Window it does not crash.

As a reproducible crash (and especially because it also affects non crypto mails) this gets High priority.

Sadly we just did a Release :-/ Maybe we can upload a fixed GpgOL Binary for users affected by this issue.

aheinecke changed the task status from Open to Testing.May 4 2018, 9:38 AM

This crash was new in Gpg4win-3.1.0 introduced with: dc48589b3d429d7d156c75b4e7bc784b140f40ce

When a reply is cancled this way outlook creates and empty, temporary mail object. When GpgOL looked at this object it made a mistake and caused the crash.

If you like you can replace your gpgol.dll in the Gpg4win\bin folder with the "2.1.2-beta5" from
http://files.gpg4win.org/Beta/gpgol/

(or in bin_64 with the 64 bit gpgol.dll if your Outlook is 64bit).

This version contains the fix.

Thank you for the quick turn-around! I especially appreciate the difficulty of out-of-release-cycle changes.

aheinecke closed this task as Resolved.Jun 18 2018, 4:03 PM

Fix is released in Gpg4win-3.1.2