GpgOL causes Outlook 2016 crash with specific message
Closed, ResolvedPublic

Description

Windows 10 Pro x64, 17134.48
Outlook 2016 x64, Version 1804 build 9226.2126 Click to run
GpgOL 2.1.1, part of Gpg4win 3.1.1

Steps:

  1. Start Outlook, make sure that the GpgOL addin is loaded.
  2. Drag and drop the this msg to a test folder (don't do it in Inbox or the default startup folder, or you'll have a startup crash loop requiring Safe mode!)
  3. Left-click on the e-mail in preview.

Result: Outlook force closes; OK with the GpgOL disabled.

Strangely, doesn't happen if the e-mail is opened directly.

Details

Version
GpgOL 2.1.1
Breach created this task.May 11 2018, 9:22 AM
aheinecke triaged this task as Normal priority.May 14 2018, 9:00 AM
aheinecke added a project: Info Needed.
aheinecke added a subscriber: aheinecke.

Thanks for your report!

Sadly I can't reproduce any issue with that mail.

Here is how it looks for me directly after importing and when viewing it for the first time:

Are you sure that you have uploaded the correct message that caused this? As this is a "draft" and does not have any encryption properties I don't see how GpgOL could be triggered on this.

If this is the right message the next step would probably be to enable GpgOL debugging as described under: https://wiki.gnupg.org/TroubleShooting#Enable_GpgOL_debugging (Enable GpgOL debugging) and attach the log here. Maybe it will point us in the right direction.

Hi and thanks. Yes, I consistently reproduce. Here's the log file.

Regards,
Alexander

aheinecke changed the task status from Open to Testing.

Argh! From the log it looks very much like another incarnation of the issue fixed in T3960 (Same underlying reason)

Could you please replace your gpgol.dll in the Gpg4win\bin_64 folder with the "2.1.2-beta5" from https://files.gpg4win.org/Beta/gpgol/2.1.2-beta5_x64/

To confirm that this also fixes your issue.

:-/ We probably need to release a new version with this fix soon.

Thanks. Confirmed - no crash with the beta5 dll.

aheinecke closed this task as Resolved.
aheinecke claimed this task.

Thanks for testing. A new Gpg4win release will come soon.