Kleopatra change expiry date on year doesn't work
Closed, ResolvedPublic

Description

Windows 10 Pro 17314.48
Kleopatra 3.1.1

Example steps:

  1. OpenPGP key expiring 26 September 2018
  2. Change expiry date to 26 September 2019 (just change the year using the UI control)
  3. Confrm -> confirmation messages says OK

Result: No change - refresh - no change.

If I change together with the date - e.g. to 30/09/2019 it works OK.

Breach created this task.May 18 2018, 10:59 PM
Breach updated the task description. (Show Details)
aheinecke triaged this task as Normal priority.
aheinecke added a subscriber: aheinecke.

Thanks. I'll look into it. It's possible that in our tests we only changed the complete date.

Had a bit trouble reproducing it. It worked for me.

But I found something that does not work and it might explain your issue. If you just change the year or the month not through the "calendar" left / right buttons but by editing the year in the titlebar. If you then select change before clicking in the calender again to select a date. It won't work.

Will be fixed.

aheinecke changed the task status from Open to Testing.Jun 1 2018, 4:21 PM

Ok You could notice it because if the year changes there was no "blue" selected date in the current page.

I've changed it now so that always a date of the currently visible page is selected. This is more intutive IMO.

Thanks. Yes, I think that's it. Here's a video just in case.

aheinecke closed this task as Resolved.Jun 18 2018, 4:04 PM

Forgot to comment. Yes what is in the video is also what I thought.

Fix is released with Gpg4win-3.1.2 I think this can be resolved now.

huowen raised the priority of this task from Normal to High.Mar 7 2019, 8:20 AM
huowen added a subscriber: huowen.

Hi,aheinecke。my kleopatra version is "kleopatra Version 3.1.4-gpg4win-3.1.5".and when change expiry date, i enter a wrong passphrase or choose "cancle". it shows successfully. what can i do for solve this question. thanks.

huowen added a comment.Mar 7 2019, 8:24 AM
This comment was removed by huowen.

Hello,
I've opened T4395 for this to keep better track of it as this task was about another issue.

Regards,
Andre