moving signed or encrypted mails in Outlook fails
Closed, InvalidPublic

Description

First scenario: Using Outlook 2016 under Win 7 that's connected to Exchange 2016:
If I have signed or encrypted mails in my postbox and wanna move them to another folder, it simply happens nothing. Independend if I use the ribbon menue, the context menue or simply try to move it by drag and drop. This happens with any folder: Either a "local" within my own exchange postbox, or a local pst where I archive my mails or the postbox of another exchange user.

Why I know it is connected with GpgOL / GPG4win: If I deactivate GpgOL I can move mails to any folder, no matter where the goal is.

Another hint: Sometimes (not 100% reproducable, but maybe it helps finding the reason) it works when I mark a not signed / encrypted mail and move the mail to its target folder without highlighting the mail I wanna move.
If I deactive the GpgOL option "automatically decrypt receipients key" it changes nothing, still I cannot move the mails.

To mention it explicitly: the is no error message, no hint why it cannot be moved. It simply happens nothing.

Same behavior I can reproduce with Outlook 2010 under Win 10 / GpgOL 2.1.1 / GPG4win with an IMAP account: If there is a signed or encrypted mail in my postbox I cannot move it to another folder (doesn't matter if another IMAP folder or a local folder in my PST) until I deactivate the AddIn GpgOL.

As descripbed above I sometimes can move mails if there is a non-pgp mail highlighted. So maybe there is an "exclusive access" to that mails by GpgOL so that they are prevented from any change like moving to another location.

I'm not a programmer but I hope the desciption is good enough for being understandable and helpful.

Kind regards

Details

Version
GpgOL 2.1.1 / GPG4win 3.1.1
NTSIMM created this task.May 29 2018, 12:29 PM
JJworx added a subscriber: JJworx.May 29 2018, 12:45 PM

This is well-known and can't be changed without a lot of hassle. There is a work-around:

  • Deselect the mail by selecting another mail.
  • Drag-n-drop the mail to be moved.

Sadly deselecting a mail doesn't help always. Most of the time I cannot move the mails even then. So the only reliable workaround is to deactivate the Addin - what cannot be the goal, at least it is not mine ;-).

If it is "well known" - can you please serve me a link with more detailed information about this issue and why it is a lot of work to solve it? I sadly didn't find any during my research.

aheinecke closed this task as Invalid.Jun 1 2018, 9:26 AM
aheinecke added a project: Duplicate.
aheinecke added a subscriber: aheinecke.

Thanks for your report, but as JJworx already said this is sadly one of the known issues to which we don't yet have a good idea how to fix it. In T3459 there is an animation what is meant by "unselecting" the mails.

I'm closing this as duplicate of T3459 If you have further comments please use T3459 .