Kleopatra: Improve handling of MDC errors
Closed, ResolvedPublic

Description

This should have probably been done for the 3.1.2 release. So I give it high priority as it should definitely done before the next release.

We are starting to get reports by users that files fail to decrypt with Gpg4win 3.1.2 and they only see the generic "Decryption Failed" error. (e.g. https://wald.intevation.org/forum/message.php?msg_id=6037 )

I think the problem is in GPGME actually. (Also see T3714 ) As the decryption result should provide the correct error. But we might also use the new flag for legacy no mdc to improve the handling in Kleopatra.

We have two cases:

  1. No MDC with a "modern" cipher algo

In that case we don't get any status from GnuPG except "Decryption Failed"

  1. No MDC with an "old" cipher algo

This is already handled and provided by gpgme++ with legacyCipherNoMDC

Both cases currently look like this:


Which is very bad as it gives users no indication what went wrong.

aheinecke changed the task status from Open to Testing.Jul 4 2018, 12:31 PM

Now we have this:

aheinecke closed this task as Resolved.Sep 4 2018, 9:22 AM

Gpg4win-3.1.3 was released.