Sending a mail with Office attachments fails on Outlook 2016 with gpg4win 3.1.3 (GPGOL 2.3.0)
Closed, ResolvedPublic

Description

When I try to send a mail with Office attachments (xlsx, docx), it does not work.
(It DOES work with .txt attachments!)

The mail composer window stays on the screen as if I did not press on the Send button.
If I press the Send button again, I get an error message:

"Fehler bei diesem Vorgang. Die Nachrichtenschnittstellen haben einen unbekannten Fehler zurückgeliefert. Falls das Problem weiter besteht, starten Sie Outlook neu."

I'll attach a debug file.

che created this task.Sep 6 2018, 10:18 AM

Here's the debug log file.

aheinecke triaged this task as High priority.Sep 6 2018, 10:42 AM
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

Thanks!

I can reproduce the issue and give it high priority. This is a curious problem of Outlook triggered by the improved send code in Gpg4win 3.1.3.

An ugly workaround is to save the mail as draft and then send it from the inline editor.

aheinecke renamed this task from Sending a mail with attachments fails on Outlook 2016 with gpg4win 3.1.3 (GPGOL 2.3.0) to Sending a mail with Office attachments fails on Outlook 2016 with gpg4win 3.1.3 (GPGOL 2.3.0).Sep 6 2018, 10:43 AM
aheinecke changed the task status from Open to Testing.Sep 6 2018, 5:32 PM

I was unable to figure out what the difference is between the handling of Office files and other files and why it comes to this error.

What I did is to handle the error and fall back to a lower level API call to send the mail. We do usually not use this API because it is pretty unstable and lead to crashes. But I think it is stable now in the way we call it here. But this needs more testing before any release.

If you like you can help by confirming that it also works for you by installing 2.3.1-beta11-STABLE-BRANCH-2-3 from https://files.gpg4win.org/Beta/gpgol/ as described under: https://wiki.gnupg.org/TroubleShooting#Manually_update_GpgOL_to_a_beta

che added a comment.Sep 6 2018, 7:40 PM

I just tried the newest beta and I can confirm that sending Office attachments does work for me with this version.

Thanks a lot for the fast reaction!

I've uploaded a Gpg4win installer with this fix (3.1.4-beta3) to https://files.gpg4win.org/Beta/current/

But for me the alternative codepath used now is still unstable and crashes sometimes.

I confirm I have the same problem but, unfortunately, the beta did not help.

aheinecke changed the task status from Testing to Open.Nov 5 2018, 3:55 PM
aheinecke lowered the priority of this task from High to Normal.

There is still at least one report claiming that this still happens for large attachments. I could not reproduce it.

aheinecke closed this task as Resolved.Nov 5 2018, 4:00 PM

A wait, we have T4203 for the continuing problems. So let's close this.

JW-D added a comment.Tue, Nov 13, 10:16 AM

Default settings in Outlook are as following: (i) S/MIME encryption disabled, (ii) S/MIME signature enabled.

If I intend to send a PGP mail, I manually disable S/MIME signature in Outlook and I enable PGP (signature & encryption). Two cases can happen, depending of the attachement:

(1) If no attachment or only a txt attachment is attached, it can be transmitted without problems.

(2) If a PDF file or an office document is attached, it fails to be sent out. If I enable in the GpgOL, fault analysis (Fehlersuche), and then I enable "Block Outlook by encryption and signatures" and I enable "Block Outlook by verfication" it works even with PDF or Office document attached.

I tried it several times, and it is always reproducible for me!

This comment was removed by lorenzog.