Mails with attachments cannot be sent
Closed, DuplicatePublic

Description

Hello,

I using Win 10, 64 bit, Gpgp4win 3..1.3 and Outlook 2016 with GpgOL 2.3.0 Addon. If I want to write an encrypted and / or signed e-mail with an attachment which is not in ASCII format, a crash by sending appears (after I entered my private key). Outlook must be manually re-loaded and I can find my mail in the drafts folder. It is not possible for me to send it out from where. No error message is delivered.

The situation is different, if no attachment or only an ASCII attachment is used. Then Outlook crashes as well, but loads automatically in few seconds again and the file is automatically copied into the drafts folder and will be automatically delivered from where after reloading.

This situation is new and it was not observed in older versions. It does not matter whether I attach a PDF or Office document, it fails always. Only ASCII files could be transmitted so for. I would appreciate your support! THANKS

Details

Version
Gpg4win 3.1.3
JW-D created this task.Sep 30 2018, 9:03 AM

Thanks for your analysis and the report. The good news is that we had this already reported and have fixed it.

We are aiming to have a release this week that includes this fix. In the meantime you can use a pre release installer:

https://files.gpg4win.org/Beta/gpg4win-3.1.4-beta6/gpg4win-3.1.4-beta6.exe

JW-D added a comment.Oct 16 2018, 12:02 PM

Hello,

I decided today to install the beta version and give it a try, because the final version is not yet released. I still facing major problems, see attachment. The mail will not be delivered, but Outlook does not crash as before.

I would appreciate it, if we could overcome this problem soon. Unfortunately I cannot often use gnupg4win, but at the moment I cannot use it at all. Because, if I have to opportunity to use it, I have attachment to protect.

I look forward to your comment.

Best regards,

Juergen Walter

-----Ursprüngliche Nachricht-----
Von: aheinecke (Andre Heinecke) <noreply@dev.gnupg.org>
Gesendet: Montag, 1. Oktober 2018 08:35
An: Juerg_Walter@t-online.de
Betreff: [Task] [Commented On] T4162: Mails with attachments cannot be sent

aheinecke added a comment.

Thanks for your analysis and the report. The good news is that we had this already reported and have fixed it.

We are aiming to have a release this week that includes this fix. In the meantime you can use a pre release installer:

https://files.gpg4win.org/Beta/gpg4win-3.1.4-beta6/gpg4win-3.1.4-beta6.exe

TASK DETAIL
https://dev.gnupg.org/T4162

EMAIL PREFERENCES
https://dev.gnupg.org/settings/panel/emailpreferences/

To: aheinecke
Cc: aheinecke, JW-D, Rafixmod, ccharabaruk, gp_ast