moving encrypted mails out of Junk folder fails
Closed, ResolvedPublic

Description

Up till quite recently (3.1.2?) encrypted mails couldn't be moved at all, but for a workaround where a different mail is marked and the mouse is used to move the unmarked mail.

This is still (3.1.4) the case in the Junk folder. This is a problem, because I don't receive Junk often and the encrypted content leads Outlook to mistakenly put those mails there. So typically there are only encrypted regular mail(s) in the Junk folder, and I can't move the remaining last mail at all, but for a workaround for the workaround ;)

  • move a regular non-signed, non-encrypted mail to Junk
  • mark it there
  • move the encrypted mail by mouse
  • move the regular mail back
JJworx created this task.Oct 17 2018, 10:56 AM
aheinecke triaged this task as Normal priority.Oct 18 2018, 12:20 PM
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

There was a report about this in the past T3956
I tried it out then with a junk folder and for me it worked so I closed the issue as a duplicate of the general moving mail problem.

If you say that it does not work there must have been something wrong with my test. I'll try to test it again with an Exchange server. I'm not sure if I tested with exchange back then.

maybe a setting is also involved. marking the mail in the Junk folder gives:

Am 18.10.2018 um 12:20 schrieb aheinecke (Andre Heinecke):

aheinecke triaged this task as "Normal" priority.
aheinecke claimed this task.
aheinecke added a comment.

There was a report about this in the past T3956
https://dev.gnupg.org/T3956
I tried it out then with a junk folder and for me it worked so I
closed the issue as a duplicate of the general moving mail problem.

If you say that it does not work there must have been something wrong
with my test. I'll try to test it again with an Exchange server. I'm
not sure if I tested with exchange back then.

*TASK DETAIL*
https://dev.gnupg.org/T4188

*EMAIL PREFERENCES*
https://dev.gnupg.org/settings/panel/emailpreferences/

*To: *aheinecke
*Cc: *aheinecke, JJworx, Rafixmod, ccharabaruk, gp_ast

  • This is an automated email from the GnuPG development hub. If you have registered in the past at https://bugs.gnupg.org/ your account was migrated automatically. You can visit https://dev.gnupg.org/ to set a new password and update your email preferences.

My pic didn't appear inline, so I'll add it again as attachment

Am 18.10.2018 um 12:20 schrieb aheinecke (Andre Heinecke):

aheinecke triaged this task as "Normal" priority.
aheinecke claimed this task.
aheinecke added a comment.

There was a report about this in the past T3956
https://dev.gnupg.org/T3956
I tried it out then with a junk folder and for me it worked so I
closed the issue as a duplicate of the general moving mail problem.

If you say that it does not work there must have been something wrong
with my test. I'll try to test it again with an Exchange server. I'm
not sure if I tested with exchange back then.

*TASK DETAIL*
https://dev.gnupg.org/T4188

*EMAIL PREFERENCES*
https://dev.gnupg.org/settings/panel/emailpreferences/

*To: *aheinecke
*Cc: *aheinecke, JJworx, Rafixmod, ccharabaruk, gp_ast

  • This is an automated email from the GnuPG development hub. If you have registered in the past at https://bugs.gnupg.org/ your account was migrated automatically. You can visit https://dev.gnupg.org/ to set a new password and update your email preferences.

Thanks. I've never seen that, so my test definitely did not test moving junk mails.

I can reproduce that it won't be moved.

@JJworx I'm curious does it work for you to decrypt the messages in the junk folder? For me it fails.

It just looks like this:

JJworx added a comment.Nov 5 2018, 4:40 PM

Yes, I also can't decrypt the files there. As Outlook warns about
restricting access to attachments and active contents, the reason is
clear. The mail must be moved elsewhere.

Am 05.11.2018 um 16:10 schrieb aheinecke (Andre Heinecke):

aheinecke added a comment.

I can reproduce that it won't be moved.

@JJworx https://dev.gnupg.org/p/JJworx/ I'm curious does it work for
you to decrypt the messages in the junk folder? For me it fails.

It just looks like this:

F500178: image.png https://dev.gnupg.org/F500178

*TASK DETAIL*
https://dev.gnupg.org/T4188

*EMAIL PREFERENCES*
https://dev.gnupg.org/settings/panel/emailpreferences/

*To: *aheinecke
*Cc: *aheinecke, JJworx, Rafixmod, ccharabaruk, gp_ast

  • This is an automated email from the GnuPG development hub. If you have registered in the past at https://bugs.gnupg.org/ your account was migrated automatically. You can visit https://dev.gnupg.org/ to set a new password and update your email preferences.

Yes I see the problem and have a fix for it. I'm just trying to make it nice now :-)

The problem is that we get an unexpected internal error when Outlook blocks access to the attachments internally. And because of that error we abort decryption and never register the event handler to catch the move event.

Quick fix would be to abort earlier but then it will show just an empty mail and no indication that it is a crypto mail. So now I'm trying to explicitly detect Junk and add a temporary category like: "GpgOL: Crypto message can't be handled in Junk folder"
So that there is an indication for users that it is in fact a crypto message.

aheinecke changed the task status from Open to Testing.Nov 6 2018, 9:22 AM

Works nicely now. I added a "yellow" warning to indicate that the message is a crypto message that can't be handled by GpgOL in the Junk folder. I see no way to actually decrypt in the Junk folder as we are not allowed to access attachments.

If you like a binary is available under: https://files.gpg4win.org/Beta/gpgol/2.3.2-beta26/ This should also fix the instability when looking at S/MIME mails

aheinecke closed this task as Resolved.Mon, Nov 19, 10:27 AM

Was released with 3.1.5