GPG Error - version >= 1.25... no
Open, NormalPublic

Description

I'm installing into /var/tmp for testing. I've built and installed libgpg-error 1.35:

$ ls /var/tmp/lib64/
charset.alias        libgpg-error.la         libiconv.so.2.6.0
libbz2.a             libgpg-error.so         libz.a
libcharset.a         libgpg-error.so.0       libz.so
libcharset.la        libgpg-error.so.0.26.1  libz.so.1
libcharset.so        libiconv.la             libz.so.1.2.11
libcharset.so.1      libiconv.so             pkgconfig
libcharset.so.1.0.0  libiconv.so.2           preloadable_libiconv.so

And:

$ ls /var/tmp/lib64/pkgconfig/
gpg-error.pc  zlib.pc

However, when I try to configure libgcrypt, it ends with:

checking for gpg-error-config... no
checking for GPG Error - version >= 1.25... no
configure: error: libgpg-error is needed.
                See ftp://ftp.gnupg.org/gcrypt/libgpg-error/ .

Here are the variables used for libgcrypt configure. They are the same variables used for libgpg-error.

PKGCONFPATH: /var/tmp/lib64/pkgconfig
   CPPFLAGS: -I/var/tmp/include -DNDEBUG
     CFLAGS: -g2 -O2 -march=native -fPIC
   CXXFLAGS: -g2 -O2 -march=native -fPIC
    LDFLAGS: -L/var/tmp/lib64 -Wl,-R,/var/tmp/lib64 -Wl,--enable-new-dtags
     LDLIBS: -ldl -lpthread

Here is the full configure for libgcrypt: :

JW created this task.Mar 7 2019, 8:28 PM
JW updated the task description. (Show Details)
JW updated the task description. (Show Details)
JW updated the task description. (Show Details)
JW updated the task description. (Show Details)Mar 7 2019, 8:32 PM
JW updated the task description. (Show Details)Mar 7 2019, 8:51 PM
JW updated the task description. (Show Details)
JW added a comment.EditedMar 7 2019, 9:01 PM

Libassuan 2.5.3 has a similar problem:

checking for GPG Error - version >= 1.17... no
configure: error: libgpg-error was not found
Failed to configure libassuan

Here is the full configure for libassuan:

werner added a subscriber: werner.

FWIW:
The first config.log is from a gnutls build.
The second for libassuan 2.5.3 and has been configured:

./configure --enable-shared --prefix=/var/tmp --libdir=/var/tmp/lib64
JW added a comment.Mar 8 2019, 10:33 AM

Similar issue with ntbtls:

...
configure: checking for cc features
checking if gcc ignores unknown -Wno-* options... yes
checking if gcc supports -Wpointer-arith... yes
configure:
***
*** You need libgcrypt to build this program.
**  This library is for example available at
***   ftp://ftp.gnupg.org/gcrypt/libgcrypt/
*** (at least version 1.6.0 (API 1) is required.)
***
configure:
***
*** You need libksba to build this program.
*** This library is for example available at
***   ftp://ftp.gnupg.org/gcrypt/libksba/
*** (at least version 1.2.0 using API 1 is required).
***
configure: error:
***
*** Required libraries not found. Please consult the above messages
*** and install them before running configure again.
***
Failed to configure ntbtls

And:

ntbtls-0.1.2$ ls /var/tmp/lib64/libksba.*
/var/tmp/lib64/libksba.la  /var/tmp/lib64/libksba.so.8
/var/tmp/lib64/libksba.so  /var/tmp/lib64/libksba.so.8.11.6

ntbtls-0.1.2$ ls /var/tmp/lib64/libgcrypt.*
/var/tmp/lib64/libgcrypt.la  /var/tmp/lib64/libgcrypt.so.20
/var/tmp/lib64/libgcrypt.so  /var/tmp/lib64/libgcrypt.so.20.2.4

Here is the full configure for ntbtls:

gniibe claimed this task.Mon, May 13, 8:35 AM
gniibe triaged this task as Normal priority.
gniibe added a subscriber: gniibe.

It is because you don't have ${prefix}/bin in your PATH.
Please build having /var/tmp/bin in your PATH.

I'm not sure if it's (autoconf's) users responsibility to make sure it's in PATH. Let me check.