dirmngr enters a loop when the keyserver returns 503 error
Closed, ResolvedPublic

Description

The dirmngr continuously restarts the lookup if the keyserver returns 503 error.

$ dirmngr
dirmngr[16930]: No ldapserver file at: '/home/test/.gnupg/dirmngr_ldapservers.conf'
dirmngr[16930.0]: permanently loaded certificates: 132
dirmngr[16930.0]: runtime cached certificates: 0
dirmngr[16930.0]: trusted certificates: 132 (131,0,0,1)

  1. Home: /home/test/.gnupg
  2. Config: [none]

OK Dirmngr 2.2.16 at your service
KEYSERVER --clear hkps://keys.fedoraproject.org:443
OK
KS_GET -- 0x8657980D9AB51E50
dirmngr[16930.0]: resolve_dns_addr for 'keys.fedoraproject.org': 'keys.fedoraproject.org' [already known]
dirmngr[16930.0]: resolve_dns_addr for 'keys.fedoraproject.org': 'keys.fedoraproject.org' [already known]
dirmngr[16930.0]: number of system provided CAs: 152
dirmngr[16930.0]: error accessing 'https://keys.fedoraproject.org:443/pks/lookup?op=get&options=mr&search=0x8657980D9AB51E50': http status 503
S PROGRESS tick ? 0 0
dirmngr[16930.0]: selecting a different host due to a 503 (Service Unavailable)
dirmngr[16930.0]: error accessing 'https://keys.fedoraproject.org:443/pks/lookup?op=get&options=mr&search=0x8657980D9AB51E50': http status 503
S PROGRESS tick ? 0 0
dirmngr[16930.0]: selecting a different host due to a 503 (Service Unavailable)
dirmngr[16930.0]: error accessing 'https://keys.fedoraproject.org:443/pks/lookup?op=get&options=mr&search=0x8657980D9AB51E50': http status 503
dirmngr[16930.0]: selecting a different host due to a 503 (Service Unavailable)
dirmngr[16930.0]: error accessing 'https://keys.fedoraproject.org:443/pks/lookup?op=get&options=mr&search=0x8657980D9AB51E50': http status 503
S PROGRESS tick ? 0 0
dirmngr[16930.0]: selecting a different host due to a 503 (Service Unavailable)
dirmngr[16930.0]: error accessing 'https://keys.fedoraproject.org:443/pks/lookup?op=get&options=mr&search=0x8657980D9AB51E50': http status 503
dirmngr[16930.0]: selecting a different host due to a 503 (Service Unavailable)
dirmngr[16930.0]: error accessing 'https://keys.fedoraproject.org:443/pks/lookup?op=get&options=mr&search=0x8657980D9AB51E50': http status 503
S PROGRESS tick ? 0 0
dirmngr[16930.0]: selecting a different host due to a 503 (Service Unavailable)
dirmngr[16930.0]: error accessing 'https://keys.fedoraproject.org:443/pks/lookup?op=get&options=mr&search=0x8657980D9AB51E50': http status 503
^C

t8m created this task.Jul 1 2019, 6:20 PM
werner triaged this task as High priority.
werner added a subscriber: werner.

(See T4175 why this changed in 2.2.12.)

werner claimed this task.Jul 3 2019, 5:08 PM
werner closed this task as Resolved.Jul 3 2019, 5:42 PM

That was pretty easy to reproduce thanks to your still not working server.