Encrypted file appears to not be encrypted by recipients public key
Closed, InvalidPublic

Description

Encrypting a stand-alone Windows file with sender's and recipient's public keys. When done using Kleopatra GUI, the recipient's tool reports that the only key used was the sender's (and since it doesn't recognize that the recipient's key was also used, the recipient is unable to decrypt the file). When sender encrypts with both sender's and recipient's public keys using either GPA (Windows) or GPG (DOS cmd-line), the recipient's tool decrypts the file correctly... only Kleopatra output files exhibit the problem, and only when encrypting standalone files. The clipboard method of encryption for the same two keys works.

Sender: 3.1.8-gpg4win-3.1.8 5.55.0, Gpg4win (Kleopatra) on Windows 10 Enterprise
Recipient: GPGTools/GPGSuite on MAC OS

Details

Version
3.1.8-gpg4win-3.1.8 5.55.0, Gpg4win (Kleopatra)
aheinecke closed this task as Invalid.Mon, Jan 27, 9:36 AM
aheinecke added a subscriber: aheinecke.

Hi,

I have difficutlty to accept that as an issue in our tracker. Somehow the GUI for Kleopatra appears to be confusing for your "Sender" which apparently is not you, correct? This results in the wrong keys selected for encryption.
With this amount of information I cannot see any path of change for our software.
Could you maybe provide a screenshot how the recipient selection looks for your user in Kleopatra, so that we can discover why it might be confusing or why the recipients key is not selected correctly?

I'm setting this issue as "Invalid" in the meantime. Not out of disrespect or so, only because I don't see how the information from this issue can currently lead to a change in our software. I can change the status later again.

Thanks,
Andre

Hi Andre,

  1. I am the sender, and can guarantee both correct keys were used. The same two keys do work in the Kleopatra clipboard tool (with recipient tool's email parser) , just not with standalone files (at least not with his file decryption be tool).
  1. It could be a user error on my part, but the Kleopatra GUI is showing both keys with check marks, so I have trouble imagining what I could do different.
  1. Recipient is not using Kleopatra, as noted in the original ticket. It is possible (and I suspect, likely) that the problem is an incompatibility between these two tools. If this is the case, then we need to find which tool is not following the standard, or perhaps the standard is ambiguous.
  1. Since filing the ticket I have discovered that if I (sender) use command line GPG (ugh!), the recipient can decrypt the file with his tool. This seems to point the finger towards Kleopatra as the more likely cause of the problem.
  1. There was a screenshot included in the original ticket showing very clearly the recipients tool doesn't recognize the presence of a second (i.e. recipient's) key.

I am attaching the screen shot from the recipient’s tool again, for your convenience.
I am also adding a screen shot of the my (i.e., sender’s) set-up in Kleopatra.
Rich

G. Richard Newell
Assoc. Technical Fellow, FPGA Business Unit, Microchip Technology
(408) 643-6146 (office), (408) 882-4785 (mobile), +1 (925) 478-7258 (Skype)
PGP: (2009 DSA-1024, ELG-4096) B751 FC13 8B4E 49DA 2270 35A2 20E4 E66A D0D0 2E34

     (2016 SSA-4096, RSA-4096) 65F5 CCD6 23B3 BD3D CEDE AB58 171F F4DE E7D0 3ECA

From: aheinecke (Andre Heinecke) [mailto:noreply@dev.gnupg.org]
Sent: Monday, January 27, 2020 12:37 AM
To: richard.newell@microsemi.com
Subject: [Task] [Closed] T4824: Encrypted file appears to not be encrypted by recipients public key

EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
aheinecke closed this task as "Invalid".
aheinecke added a comment.

Hi,

I have difficutlty to accept that as an issue in our tracker. Somehow the GUI for Kleopatra appears to be confusing for your "Sender" which apparently is not you, correct? This results in the wrong keys selected for encryption.
With this amount of information I cannot see any path of change for our software.
Could you maybe provide a screenshot how the recipient selection looks for your user in Kleopatra, so that we can discover why it might be confusing or why the recipients key is not selected correctly?

I'm setting this issue as "Invalid" in the meantime. Not out of disrespect or so, only because I don't see how the information from this issue can currently lead to a change in our software. I can change the status later again.

Thanks,
Andre

TASK DETAIL
https://dev.gnupg.org/T4824

EMAIL PREFERENCES
https://dev.gnupg.org/settings/panel/emailpreferences/

To: aheinecke

Cc: aheinecke, grichardnewell, Neurone, Rafixmod, ccharabaruk, gp_ast

This is an automated email from the GnuPG development hub. If you have registered in the past at https://bugs.gnupg.org/ your account was migrated automatically. You can visit https://dev.gnupg.org/ to set a new password and update your email preferences.