Release GnuPG 2.2.22
Closed, ResolvedPublic

Description

Noteworthy changes:

  • gpg: Change the default key algorithm to rsa3072.
  • gpg: Add regular expression support for Trust Signatures on all platforms. [T4843]
  • gpg: Fix regression in 2.2.21 with non-default --passphrase-repeat option. [T4991]
  • gpg: Ignore --personal-digest-prefs for ECDSA keys. [T5021]
  • gpgsm: Make rsaPSS a de-vs compliant scheme.
  • gpgsm: Show also the SHA256 fingerprint in key listings.
  • gpgsm: Do not require a default keyring for --gpgconf-list. [T4867]
  • gpg-agent: Default to extended key format and record the creation time of keys. Add new option --disable-extended-key-format.
  • gpg-agent: Support the WAYLAND_DISPLAY envvar. [T5016]
  • gpg-agent: Allow using --gpgconf-list even if HOME does not exist. [T4866]
  • gpg-agent: Make the Pinentry work even if the envvar TERM is set to the empty string. [T4137]
  • scdaemon: Add a workaround for Gnuk tokens <= 2.15 which wrongly incremented the error counter when using the "verify" command of "gpg --edit-key" with only the signature key being present.
  • dirmngr: Better handle systems with disabled IPv6. [T4977]
  • gpgpslit: Install tool. It was not installed in the past to avoid conflicts with the version installed by GnuPG 1.4. [T5023]
  • gpgtar: Handle Unicode file names on Windows correctly (requires libgpg-error 1.39). [T4083]
  • gpgtar: Make --files-from and --null work as documented. [T5027]
  • Build the Windows installer with the new Ntbtls 0.2.0 so that TLS connections succeed for servers demanding GCM.
werner created this task.Aug 22 2020, 2:41 PM
werner updated the task description. (Show Details)Aug 27 2020, 3:03 PM
werner set External Link to https://lists.gnupg.org/pipermail/gnupg-announce/2020q3/000447.html.
werner closed this task as Resolved.Aug 27 2020, 3:21 PM

There seems to be a problem with Gnuk and thus Nitrokey tokens with 2.2.22. We are investigating this. See T5039.

As a workaround please run

gpg --card-status

after plugging in a Gnuk or Nitrokey token.

werner added a comment.Wed, Sep 2, 4:16 PM

A bug was reported against this version which could happen also to older versions of GnuPG 2.2. In case of a crash please apply the patch over at rG8ec9573e57866dda5efb4677d4454161517484bc or wait for 2.2.23