Gpa crash when opening a non ASCII file with gpa
Closed, ResolvedPublic

Description

I have not tested with the last version. So I'm assigning this to me for now to
at least analyse the problem on Windows.

Moved out of T1624:
msg5588 Author: boehmtho Date: 2014-11-28.13:56:31

I did install gpg4win 2.2.3 which does include the fix for Umlaut. I prefer to
use GPA as frontend for encryption and decryption. For decryption, I did link
.gpg to be always opened with GPA. Unfortunatly if the File or Path to the .gpg
has an Umlaut included the GPA GUI crashes. Only if I use the open button from
GPA the file can be added to the GPA frontend and decrypted. For non-umlaut
files the link to open .gpg works fine. Do you also work on GPA bugs or do I
have to report this under the GPA category?
Thank you & regards,

Added this to 3.0 because I don't want to release any known crashes.

aheinecke closed this task as Resolved.May 14 2017, 2:46 PM

Found the problem and fixed it. The Problem is described in the commit. Basically glib always assumed it gets UTF-8 Encoded filenames even if they were provided in system locale through double click / open with / command line / drag & drop.