attachments can't be removed
Closed, ResolvedPublic

Description

When deleting an attachment it seems gone, but is in fact replaced with a numbered copy of the same file, as visible by clicking on the mail again. I accept that removing attachments will break the signature, but other than that it should be possible, or there should be a warning.

JJworx created this task.Apr 9 2018, 1:54 PM
JJworx added a comment.Apr 9 2018, 2:07 PM

In fact, renumbering of attachments happens also by just viewing them repeatedly. This likely causes multiple copies somewhere, reducing disk space.

Also, renumbering is not done correctly in a case where there is multiple dots in the file name, like a date. See attached example:

aheinecke triaged this task as Normal priority.Apr 10 2018, 8:24 AM
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

I'll go for a warning / error for now and see if I can fix the renumbering.

We can't really remove attachments. Maybe we could persistently hide them but that would probably defeat the purpose of removing them (making the mail smaller).

  • For Signed - Not encrypted mails we could offer to remove the signature when removing an attachment.
  • For Encrypted Mails there is a long standing feature request to allow "permanent decryption" then you could permanently decrypt and remove an attachment. Anything else for encrypted Mails like "re encrypting the message without the attachment" is complex and is currently far away.

Normal Prio as this is not a regression and might not make it into a 3.1.0 release.

aheinecke changed the task status from Open to Testing.Apr 12 2018, 10:16 AM

When an attachment of a crypto mail is removed it now leads to a warning.

I also think that I have fixed the cause for the renumbering issue.

I've opened T3895 for a permanent decryption / permanent removal of attachments. Maybe something for 3.2.0 ;-)

aheinecke closed this task as Resolved.Apr 13 2018, 11:22 AM

3.1.0 is released and this issue is to our knowledge fixed.

( Apart from the part that was moved out to T3895 )