dirmngr: "flush" does not flush in memory CRL's
Closed, ResolvedPublic

Description

This was raised by MTG in their testing that dumping the CRL Cache through Kleopatra does not work.

And indeed, what Kleopatra does is to send:

"dirmngr --flush" to clear the CRL Cache.
"gpgsm --call-dirmngr listcrls" to show the CRL Cache.

I can see that flush removes the files in the CRL cache but "gpgsm --call-dirmngr listcrls" lists the same CRL's before and after the flush. Killing dirmngr resolves this.

So I think dirmngr needs to also flush any in memory cache when flushing. I guess the problem is that the flush is called on a new dirmngr instance. Any advice about how Kleo should call the flush?

To reproduce:

import  http://files.intevation.de/users/aheinecke/aheinecke-2018.pem
gpgsm --with-validation -k aheinecke@intevation.de   
gpgsm --call-dirmngr listcrls
dirmngr --flush
gpgsm --call-dirmngr listcrls

I think this is low priority because that is mostly a development / testing feature and I don't think that we have any regression here.

aheinecke claimed this task.May 8 2018, 4:40 PM
aheinecke added a project: kleopatra.
aheinecke added a subscriber: werner.

Wait. Users should not have the ability in the GUI to mess with the CRL cache. That is internal / private stuff. And something for developers, so this should be removed from the GUI altogether.

Assigned back to me to remove it from the GUI.

aheinecke closed this task as Resolved.