GPA: Can't create new keys with GPGME 1.12.x
Closed, ResolvedPublic

Description

Was reported to me for Windows but I can also reproduce it with latest GPA on GNU/Linux:

Trying to create a new key fails with "gpagenkeysimpleop:c:159 Invalid Argument." On Linux it also segfaults right after that.

aheinecke raised the priority of this task from Normal to High.Mon, Nov 26, 9:16 AM

Gets reported multiple times and should be fixed for the next Gpg4win release as it is a bad first impression. (Although it can convert users to Kleopatra ;-) )

werner added a comment.Thu, Dec 6, 6:29 PM

Can you give me a reproducer on Linux. I am not able to reproduce it. What versions of gnupg and gpgme are you using (see gpa's about)

Just by going through the standard "new key wizard".


GPA 0.11.0-beta5 [70858dc]

(GPGME 1.12.1-beta68)
(GnuPG 2.2.12-beta19)

Sorry, I am still not able to replicate it:

gpa 0.11.0-beta1
gpgme 1.12.1-beta12
gnupg 2.2.12-beta15

The beta numbers might not be correct; I actually use the latest versions of gpa and gnupg; let me check gpgme.

I ran it with GPGME_DEBUG and it errors out at
GPGME 2018-12-07 10:34:32 <0x19c43> gpgme_op_genkey_start:293: error: Invalid argument <GPGME>

The check in 174af15725d4989a840ff3098996cc8a0568f724 should have been "if (!ctx || !parms)".

Kleo is not affected as it does not use the async functions.

I'll fix it.

Should we close this or do you want to investigate why the segfault happened after the error?

werner closed this task as Resolved.Fri, Dec 7, 11:54 AM

Regession due to my commit 10 days after the last release. Thus no need to do a release.