Kleopatra / Win 10 - Sign and Encrypt window doesn't show up
Closed, ResolvedPublic

Description

I observe quite annoying issue: Sign/Encrypt window doesn't appear to me which makes the app unusable.
It could be a bug related to different resolutions and scaling settings on two monitors.

Steps to reproduce:

  1. select several files on desktop
  2. open context menu
  3. click "Sign and Encrypt"

Expected result: Dialog window appears to me with parameters of signing/encryption
Actual result: I see window title in taskbar "Sign/Encrypt Files - ...". But window doesn't appear. I cannot make it visible.

Additional information:
Windows 10 Version 1909 (OS Build 18363.592)
Two monitors:

  • Laptop native 2560x1440, 150% scale
  • 2nd monitor: 1920x1080, 100% scale (this is main monitor)

Details

Version
3.1.11-Gpg4win-3.1.11 5.55.0, Gpg4win

I've downgraded to gpg4win-3.1.10 - still be reproducible...

aheinecke triaged this task as Normal priority.Jan 21 2020, 1:22 PM
aheinecke added a subscriber: aheinecke.

Thanks for the report. I have observed that the Window is sometimes opened in the background so I accept that this is an issue for Kleopatra somehow and we need to look into it. I know that your problem is a bit different but that is related.

As a quick support help. Shutdown Kleopatra: Go to %APPDATA%\kleopatra and rename the file "kleopatrarc" to "kleopatrarc.old" and try again. That should work as the last Window position / geometry of the File Encrypt dialog is saved in that file.

Result of renaming:
It helped, but only for 1st run. Then problem occurs again.
I've tried to restart the app, but it doesn't help.

I've compared kleopatrarc.old and newly created kleopatrarc and found difference in section "[SignEncryptFilesWizard]"
I've removed that section from kleopatrarc with restarting the app and it worked again! but only once :-/

I think these settings are generated in a wrong way on first show of the SignEncryptFilesWizard and then it stores new config in memory.

I believe "geometry" field value from [SignEncryptFilesWizard] can help in debug.
But I'm not sure about posting it here: does it contain any sensitive info?

I am also having this issue, but it is with Decrypt & Verify. It basically renders the app unusable. What happens is that when you click the button another window opens but it seems to be in the background, because it just looks white and it won't appear when you click on it. This happens for all files it seems.

Currently using a workaround where it seems like Kleopatra actually already stores the decrypted file in the "C:\Users\[user]\AppData\Local\Temp\kleopatra-[random string]" directory while the window hangs. If you go there you can find the decrypted file.

This bug is linked to restoring window size in case of multi-monitor multi-DPI setup.
There is QT bug report: https://bugreports.qt.io/browse/QTBUG-77385

I've applied the fix from comments of the bug report as a Kleopatra source code patch.
The bug isn't reproducible anymore.

My changes:
https://bitbucket.org/andrey-legayev/gpg4win/pull-requests/1/t4819-fix-restore-geometry

Thanks for looking into this!

As I have no muti-monitor multi-DPI test setup I'll trust your test and will apply the patch.

Patch with my fix: https://dev.gnupg.org/D498
(now I know how to submit it!)

BTW there is no .arcconfig file. I had to add it to run "arc diff"
You can merge this as well if it's needed: https://dev.gnupg.org/D499

Today I wanted to check linked issue: main window of Kleopatra doesn't remember size.
I worked on it again full day and found really good solution which is already present in KDE libs.
This is new fix for dialogs mentioned in this ticket and for MainWindow:
https://phabricator.kde.org/D28580

I believe this fix should be submitted to Kleopatra repository and merged here as a new version.
I'm revoking https://dev.gnupg.org/D498

aheinecke closed this task as Resolved.May 8 2020, 3:16 PM
aheinecke claimed this task.

Thank you for your work, appreciated. Sorry I was a bit under the weather in April and could not get back to you earlier.

You have also fixed: T4786 right?

Best Regards,
Andre

@aheinecke right, it's also fixed.